Make build errors


I have issues while the ‘make build’ command execution when I try to build the image, please, see below:

#10 37.08 Reading state information...
#10 37.17 E: Unable to locate package cmake
#10 37.17 E: Unable to locate package g++
#10 37.17 E: Couldn't find any package by regex 'g++
#10 37.17    '
#10 37.17 E: Unable to locate package gcc
#10 37.17 E: Unable to locate package git
#10 37.17 E: Unable to locate package sysstat
#10 37.17 E: Unable to locate package tree
executor failed running [/bin/sh -c echo "Installing base packages..."     && apt-get update --fix-missing     && apt-get install -y apt-utils 2> /dev/null     && apt-get install -y wget zip tzdata     && apt-get install -y libgl1-mesa-glx     && xargs -a /home/${RUNTIME_USER}/apt.txt apt-get install -y     && apt-get clean     && rm -rf /var/lib/apt/lists/* /home/${RUNTIME_USER}/apt.txt]: exit code: 123
make: *** [Makefile:58: build] Error 1

I was trying to troubleshoot the solution, however without any success. Do you have any ideas how I can manage the this problem?

Hi @sc1723,

I’m not able to reproduce the errors you’re seeing.

This StackOverflow post has a bunch of discussion about this sort of error with apt. Many of the answers discuss running apt-get update, which is something we’re already doing.

It’s possible that there may be an issue with your Docker, such as a bad cache that is getting reused. You might want to try some of the suggested Docker cleanup commands:

As a nuclear option, you could try (WARNING: this deletes things; be sure you don’t lose any work) docker system prune -a to completely wipe your local Docker stuff clean.

Hi @jayqi,

Thank you for your reply!

I have tried all these solutions from StackOverflow, however they were not helpful. In addition, I tried: cleaning cache for my local Docker, and completely removing and reinstalling Docker. However, I have the same issue. I tried this on two different Windows machines, the result was the same.

How do you think, maybe its a problem with a particular operation system version (which is quite unrealistic I believe)?

Hi @sc1723,

I don’t have a ton of experience running Docker on Windows, so I don’t know whether or not to expect any issues related to that.

In case all you’re looking for is a copy of the runtime image that you can run locally, you can use the make pull Makefile recipe to pull the latest official image from our container registry. You should then be able to run the evaluation process locally with that image.

If you are trying to build the image because you’d like to use it with local changes, then it makes sense to try to get make build working. In case you haven’t tried it already, I have had a good experience when on Windows in the past using Docker’s integration with WSL. Additionally, you may consider developing on a cloud VM that is running Linux.